1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you are not receiving an email confirmation after registering your account, send an email to SimsVIPContact@Gmail.com with your registered username, and we will validate your account.
    Dismiss Notice

Anyone's 'Ultra' speed not so Ultra after patch?

Discussion in 'Technical Discussion' started by Naria, Sep 6, 2014.

  1. Naria

    Naria

    Messages:
    21
    Likes Received:
    6
    Trophy Points:
    0
    So after updating Sims 4 last night with the patch to fix the distorted baby issue, my Speed 3, Ultra Speed... well, it just isn't ultra anymore. It works more like Speed 2.

    Can confirm this for both my desktop and my laptop.

    Did this happen to anyone else? It seems a weird thing to have been affected, but it was working as intended before.
     
  2. uhleeshuh

    uhleeshuh

    Messages:
    308
    Likes Received:
    176
    Trophy Points:
    0
    I didn't even know there was a patch! Lol I'm gonna get it and see. I hope the speed don't slow down for me too
     
  3. uhleeshuh

    uhleeshuh

    Messages:
    308
    Likes Received:
    176
    Trophy Points:
    0
    Got the patch and Ultra speed is still pretty Ultra lol sorry!
     
  4. Naria

    Naria

    Messages:
    21
    Likes Received:
    6
    Trophy Points:
    0
    I can't seem to find this issue from anyone on the EA Tech Forums either. Hmm.
     
  5. apolloallyn

    apolloallyn

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I noticed this too when I had one Sim asleep and another at work. Ultra speed only seems to happen sporadically.
     
  6. Danny50205

    Danny50205

    Messages:
    6
    Likes Received:
    3
    Trophy Points:
    0
    I have also been having the same issues, i normally use (TestingCheats) for their needs and let them get there skills built up, now it is taking forever but yesterday it was all fast. strange stuff O_0
     
  7. Naria

    Naria

    Messages:
    21
    Likes Received:
    6
    Trophy Points:
    0
    I live for the Speed 3 button. This is a terrible issue LOL
     
    uhleeshuh likes this.
  8. uhleeshuh

    uhleeshuh

    Messages:
    308
    Likes Received:
    176
    Trophy Points:
    0
    I know! If it ain't on 3 it's on P
    Speed simming lolol
     
  9. buriedwarf

    buriedwarf

    Messages:
    19
    Likes Received:
    6
    Trophy Points:
    0
    I have been having this issue since the first patch. Just sometimes ultra was actually ultra, but sometimes it was more like speed 2 or even normal speed! So I would not say that is a problem related to the patch, at least not in my case.
     
  10. SimsVIP

    SimsVIP Staff Member

    Messages:
    307
    Likes Received:
    266
    Trophy Points:
    10
    Mine is doing the same. Feels like a mix between 1 & 2. But I do think it's been that way since the start.

    I also have this issue where the keyboard numbers don't change the speed or pause. Then it does after I travel....just weird. :p
     

Share This Page