1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you are not receiving an email confirmation after registering your account, send an email to SimsVIPContact@Gmail.com with your registered username, and we will validate your account.
    Dismiss Notice

Microsoft Edge

Discussion in 'Forum Feedback and Ideas' started by AtomicSimmer, Feb 23, 2016.

  1. AtomicSimmer

    AtomicSimmer

    Messages:
    488
    Likes Received:
    182
    Trophy Points:
    10
    For some reason I get a better response posting in the forum when I use Internet Explorer in windows 10 then I do when I use Edge. It seems Edge keeps blocking something on this site.
     
  2. Kit

    Kit Mommy Mode Staff Member

    Messages:
    731
    Likes Received:
    715
    Trophy Points:
    10
    I use Chrome.
     
  3. MiffoShort1997

    MiffoShort1997

    Messages:
    462
    Likes Received:
    310
    Trophy Points:
    0
    I use Firefox and have Ad Blocker Plus enabled so I get no advertisements :) For me Firefox is quick and this site and all others I use load really quickly.

    Matthew.
     
  4. Mendota

    Mendota Site Supporter

    Messages:
    53
    Likes Received:
    23
    Trophy Points:
    10
    I use Edge with no problems. The issue with blocking ads is that you are denying revenue to the sites that that depend on them. I don't find the ads on this site intrusive (i.e as in those horrible loud auto video and audio ads.) Edge had its issues right out of the gate for me, but these days it has settled down nicely and I do like it's import feature.
     
  5. AtomicSimmer

    AtomicSimmer

    Messages:
    488
    Likes Received:
    182
    Trophy Points:
    10
    I don't think its add blocking it says something about blocking content on insecure connections everytime I go to this site on Edge.
     
  6. AtomicSimmer

    AtomicSimmer

    Messages:
    488
    Likes Received:
    182
    Trophy Points:
    10
    I think its getting better though the site has been peforming better and ive been using edge everytime I'm on here.
     
  7. Kit

    Kit Mommy Mode Staff Member

    Messages:
    731
    Likes Received:
    715
    Trophy Points:
    10
    If others with Edge don't have the problem, then it doesn't seem to be the site's performance, but your own computer's or internet's. Unfortunately I don't even know what Edge is. Lol.
     
  8. Mendota

    Mendota Site Supporter

    Messages:
    53
    Likes Received:
    23
    Trophy Points:
    10
    Edge is the new browser that is built into Windows 10. It is meant to replace Internet Explorer.
     
  9. AtomicSimmer

    AtomicSimmer

    Messages:
    488
    Likes Received:
    182
    Trophy Points:
    10
    I guess some people are not Windows 10 or as up to date yet. Eventually everyone will be on it.
     
  10. AtomicSimmer

    AtomicSimmer

    Messages:
    488
    Likes Received:
    182
    Trophy Points:
    10
    I guess some people are not Windows 10 or as up to date yet. Eventually everyone will be on it. Whats weird though is that its only this site that acts up for me other sites I go to are fine.
     

Share This Page