1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you are not receiving an email confirmation after registering your account, send an email to SimsVIPContact@Gmail.com with your registered username, and we will validate your account.
    Dismiss Notice

The Sims 4 64bit Framerate issues

Discussion in 'Technical Discussion' started by Kenter93, Dec 7, 2015.

  1. Kenter93

    Kenter93

    Messages:
    11
    Likes Received:
    4
    Trophy Points:
    0
    So on Friday the 4th EA pushed out an update for The Sims 4 that included a bunch of new fixes, map updates and the introduction of 64 bit for Windows users. A full list of patch notes can be found at SimsVIP.

    Now while the introduction of 64 bit is important for users whose computers have more than 4GB of ram some users are reporting an issue where when launching in 64bit their game starts to lag something fierce. I was having this issue as well and I have resolved this issue for myself. I have a NVidia Geforce GTX 970m and this card should be able to handle the game no problem but the 64 bit version was turning all my settings down to low-medium. Turns out my computer, even though have The Sims 4 shortcut .exe launching with the dedicated card Origin was launching the game with the integrated card for 64 bit games. How I fixed this was

    Right click on your desktop and open the NVidia Control Panel
    If not already selected go to Manage 3D Settings

    Your screen should have this open...

    [​IMG]

    If you notice, there are three options. Auto Select, High-Performance NVidia Processor and Integrated Graphics. If this is set to Auto or Integrated Graphics, change it to the High-Performance NVidia Processor and click apply then close. Now when launching The Sims 4 your game should launch with that card and this should resolve the framerate drops. Comment below if you have any questions.
     
    benji_br likes this.
  2. ManagerJosh

    ManagerJosh Ninja Staff Member

    Messages:
    157
    Likes Received:
    82
    Trophy Points:
    0
    @Kenter93, is there an application specific setting one can enable instead of enabling the systemwide one?
     
  3. Kenter93

    Kenter93

    Messages:
    11
    Likes Received:
    4
    Trophy Points:
    0
    Um, not that I've noticed. Some users have sent me emails saying that all they had to do was switch their game via the NVidia Control Panel to use the dedicated card and that worked, but didn't for others. It's odd.
     

Share This Page